Skip to main content

Pure Connect app - minimum system requirements - Knowledgebase / Internet radios / Apple/Android Pure Connect - PURE SUPPORT

Pure Connect app - minimum system requirements

Authors list

You can get the App from the Apple Store or Google Play.

You can use a iPhone, iPod Touch, iPad running iOS6.1 or above or devices running Android v.2.2 and above